Additional Unicorn Topics

Using Multiple Unicorn Windows

You may create multiple Unicorn windows through the “New” and “Open” items of the File menu.  These windows may be positioned anywhere on your screen and resized as you wish.  Use the Window menu to select a particular window.  The Window menu also has a “Next Window” item for selecting the next window.

If a window contains unsaved changes, Unicorn displays two asterisks in front of the filename in the window's title bar.  If there are no unsaved changes, two hyphens are displayed.  If a window contains unsaved changes and you are quitting Unicorn or closing the window, Unicorn asks if you want to save those changes.

You may configure the default size, keyboard, and font of a new window using the Windows tab of the Preferences dialog.


Keyboard & Font Selection

Change the current window's keyboard and/or font using the “Change Font” dialog under the Edit menu.  In the list of fonts, a font supporting the currently selected keyboard type will be listed in a green type face.

The Edit menu items “Make Text Larger” and “Make Text Smaller” will adjust the font size one point at a time.  You can also use the “Change Font...” dialog to set the font size.

The keyboard and font dialog displays a sample of the current font.  For polytonic Greek, this is the first line of the Odyssey.  For the International keyboard, the sample is the first line of the Aeneid.  The first line of Genesis is displayed for the Hebrew keyboard. Finally, for the Russian keyboards, we have the first line of Tolstoy's Anne Karenina.

Unicorn can select a keyboard and font based on a file's extension or file type.  For example, within the Files tab of the Preferences dialog, you could specify that files with a .grk extension are opened using the Greek keyboard with the font Old Vusillus Italic or that .lat files are opened using the Latin keyboard with the font Courier New;. Many other possibilities exist.  If the file's type is unrecognized, the default font for a new Window will be used.

Files with .latin, .lat, .heb, .greek, or .grk extensions will launch Unicorn when they are double-clicked on Mac OS X.  On Windows select the file, right-click, and use the “Open With” option to set Unicorn as the program that opens such files.



Using the Find dialog under the Edit menu, you can search forwards or backwards and replace incrementally, globally, or within a highlighted selection.  The keyboard mode can be toggled within the Find or Replace fields by typing Control-G (or Command-G on a Mac). By default upper and lower case distinctions and diacritical marks are ignored in a search; Greek medial and terminal sigma are considered the same letter.

One possible use of the Find dialog is searching a vocabulary list in one window while reading text in a second window.  New searches start at the beginning of a file by default; this behavior may be changed by unchecking the “Start searches at top of file” checkbox.  The “Top of File” button may be used at any point to reset a search's starting place to the beginning of the file.

The “Goto Line” menu item under the Edit menu prompts for a line number and then moves the cursor to the start of that line.


The Latin and Greek Dictionaries

You must first download the Latin and Greek dictionaries.  Then in the Dictionaries tab of the Preferences dialog, check the box enabling the dictionary, and use “File” button to specify the dictionary file's location.

Double-clicking on a word will open a dictionary window, displaying that word and its grammatical breakdown.  If there is no exact match, the dictionary will select the closest word.  The dictionary window has left and right buttons to step back and forward through the dictionary.  You can also type a word in directly into the window's search box.  The “Terse” checkbox in the Dictionaries tab of the Preferences dialog controls whether or not the grammatical breakdown of the word is displayed.

The dictionaries may be used for English to Latin or Greek lookup.  To find the Greek words whose definition contains a particular English word, you must first toggle the search box's Greek input mode by typing ESC-ESC or Control-G or Command-G.  You then type the English word or phrase and press the return key.  In the case of Latin, you must precede the word with an asterisk.  For example, typing in “*glossary” will return all the Latin words that have in their definition.  If you wish to search for part of a word, you must enclose that part in single quotes.  For example, searching for “and” will turn up entries containing the words and, thousand and husband in their definition.

You may also open a dictionary window by selecting the “Latin Dictionary” or “Greek Dictionary” item in the Tools menu.

Invoke the spelling checker by first using your cursor to select some text in a window, then choosing “Check Latin Spelling” or “Check Greek Spelling” in the Tools menu.  The results are reported in a new window.

The Latin dictionary, although large, does not have all known Latin words and their variant spellings.  It has very few proper names.  Although the dictionary can usually cope with “i” versus “j” (e.g., ianua and janua are both recognized), it does not handle “u” versus “v” (e.g., ueni for veni is not recognized).  The Latin dictionary file was designed and compiled by William Whitaker.  The Latin dictionary program itself is an independent design and implementation.

The Greek dictionary is much smaller than the Latin dictionary.  Adding more vocabulary is very straightforward.

There is currently no support for other dictionaries.



Unicorn allows you to create your own “help” menus.  The items under these menus name files that will be displayed in a new Unicorn window when they are selected.  Such a file may contain a vocabulary list, a grammar summary, or anything else.  You can thus quickly and easily consult your own set of notes.

Use the Menus tab of the Preferences dialog to add new menus or edit existing ones.  The menu information is displayed in a spreadsheet format, with each row containing a menu name, an item name belonging to that menu, and a filename.  You may select a row and edit the “Menu” or “Menu Item” fields by clicking on the field and typing in new text.  Double-clicking on the “File” field will cause a file selection dialog to appear.  You may rearrange the order in which menus or menu items appear by using the “Move Up” and “Move Down” buttons.  The “New” button will create an empty row below a selected row, or at the end of the list if there is no selected row.  The “Delete” button will delete a selected row.


The Tools Menu

In addition to the “Latin Dictionary” and “Greek Dictionary” menu items discussed above, the Tools menu has a collection of minor utilities.  In each case first use your cursor to select some text, then choose the menu item under the Tools menu.

The “Sort Lines” menu item will sort a selection alphabetically according to the first word on each line.  It will sort both English and Greek text.  It will not sort Hebrew text properly.

To understand the next two commands, a short digression on the variants of betacode is in order.  Betacode was defined by the Thesaurus Linguae Graeca (TLG) research group. Henceforth the TLG definition of betacode will be called “strict betacode”.  The Spionic font is a superset of strict betacode that uses upper and lowercase Roman letters to represent the upper and lowercase Greek letters.  Strict betacode, on the other hand, uses only uppercase Roman letters and indicates any Greek capital letters by preceding the Roman capital letter with an asterisk.  Spionic also has symbols for various combinations of diacritical marks for characters of different widths.  The betacode used by Unicorn is a subset of Spionic, dropping out most of the diacritical mark combinations, preserving the upper and lower case representations, and reassigning the tilde to represent a breve mark instead of a wide circumflex.

The “Spionic to Unicode” menu item will translate text in the Spionic encoding into Unicode.

The “Strict Betacode to Unicode” menu item will translate text using the TLG-defined betacode encoding into Unicode.

The “HTML Escape Codes” menu item is a quick way to create Unicode text suitable for embedding in webpages.  It will create a new window and copy the selected text to that window.  Every non-ASCII character, as well as the characters <>'&“, will be converted to HTML tags.

The ”Unicode Escape Codes” menu item is a debugging aid.  It will create a new window in which it displays the Unicode escape code for each character in the highlighted text.

The “Number to Character” menu item is a similar debugging aid.  If you highlight a hexadecimal number, then select “Number to Character”, the corresponding Unicode character will be displayed, provided that the current font supports that character.  If the number ends in a period, the number will be considered a decimal number.  You can use this tool to insert Unicode characters not supported by Unicorn's keyboard mapping.